summaryrefslogtreecommitdiffstats
path: root/tdelfeditor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdelfeditor/CMakeLists.txt')
-rw-r--r--tdelfeditor/CMakeLists.txt12
1 files changed, 3 insertions, 9 deletions
diff --git a/tdelfeditor/CMakeLists.txt b/tdelfeditor/CMakeLists.txt
index 19f195555..07cd731d2 100644
--- a/tdelfeditor/CMakeLists.txt
+++ b/tdelfeditor/CMakeLists.txt
@@ -35,14 +35,8 @@ tde_add_executable( tdelfeditor
##### embed scm data into important libraries ####
-# look for SCM data if present
-if( EXISTS "${CMAKE_SOURCE_DIR}/.tdescmmodule" )
- file( STRINGS "${CMAKE_SOURCE_DIR}/.tdescmmodule" TDE_SCM_MODULE_NAME )
-endif( EXISTS "${CMAKE_SOURCE_DIR}/.tdescmmodule" )
-if( EXISTS "${CMAKE_SOURCE_DIR}/.tdescmrevision" )
- file( STRINGS "${CMAKE_SOURCE_DIR}/.tdescmrevision" TDE_SCM_MODULE_REVISION )
-endif( EXISTS "${CMAKE_SOURCE_DIR}/.tdescmrevision" )
-
+# read source metadata
+tde_read_src_metadata()
tde_curdatetime( scm_embed_metadata_datetime )
if( NOT "${TDE_SCM_MODULE_NAME}" STREQUAL "" )
@@ -138,4 +132,4 @@ if( NOT "${TDE_SCM_MODULE_NAME}" STREQUAL "" )
COMMENT "Storing SCM metadata in tdehtml/libtdehtml.so"
)
endif( )
-endif( ) \ No newline at end of file
+endif( )