summaryrefslogtreecommitdiffstats
path: root/tdeparts/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdeparts/CMakeLists.txt')
-rw-r--r--tdeparts/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/tdeparts/CMakeLists.txt b/tdeparts/CMakeLists.txt
index 341734461..497b82ced 100644
--- a/tdeparts/CMakeLists.txt
+++ b/tdeparts/CMakeLists.txt
@@ -40,9 +40,15 @@ install( FILES
##### other data ################################
-install( FILES
+foreach( _desktop
kpart.desktop krop.desktop krwp.desktop browserview.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+)
+ tde_create_translated_desktop(
+ SOURCE ${_desktop}
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeparts-desktops
+ )
+endforeach()
#### tdeparts #####################################