summaryrefslogtreecommitdiffstats
path: root/tdeprint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdeprint/CMakeLists.txt')
-rw-r--r--tdeprint/CMakeLists.txt17
1 files changed, 15 insertions, 2 deletions
diff --git a/tdeprint/CMakeLists.txt b/tdeprint/CMakeLists.txt
index 472158713..72c8517e7 100644
--- a/tdeprint/CMakeLists.txt
+++ b/tdeprint/CMakeLists.txt
@@ -59,9 +59,22 @@ install( FILES
##### other data ################################
install( FILES kprintpreviewui.rc DESTINATION ${CONFIG_INSTALL_DIR}/ui )
-install( FILES testprint.ps specials.desktop DESTINATION ${DATA_INSTALL_DIR}/tdeprint )
-install( FILES tdeprintd.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kded )
+
+install( FILES testprint.ps DESTINATION ${DATA_INSTALL_DIR}/tdeprint )
+
+tde_create_translated_desktop(
+ SOURCE specials.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/tdeprint
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeprint-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE tdeprintd.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/kded
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeprint-desktops
+)
install( FILES tdeprintrc DESTINATION ${CONFIG_INSTALL_DIR} )
+
install( FILES tdeprintrc.upd DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )