summaryrefslogtreecommitdiffstats
path: root/tdeprint/foomatic/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdeprint/foomatic/Makefile.am')
-rw-r--r--tdeprint/foomatic/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/tdeprint/foomatic/Makefile.am b/tdeprint/foomatic/Makefile.am
new file mode 100644
index 000000000..7a57fd40e
--- /dev/null
+++ b/tdeprint/foomatic/Makefile.am
@@ -0,0 +1,20 @@
+INCLUDES = -I$(top_srcdir)/tdeprint $(all_includes)
+
+kde_module_LTLIBRARIES = tdeprint_foomatic.la
+
+tdeprint_foomatic_la_SOURCES = kmfoomaticfactory.cpp \
+ kmfoomaticmanager.cpp \
+ kfoomaticprinterimpl.cpp
+tdeprint_foomatic_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+tdeprint_foomatic_la_LIBADD = $(top_builddir)/tdeprint/management/libtdeprint_management.la
+tdeprint_foomatic_la_METASOURCES = AUTO
+
+noinst_HEADERS = kmfoomaticmanager.h \
+ kfoomaticprinterimpl.h
+
+bin_PROGRAMS = make_driver_db_foomatic
+
+make_driver_db_foomatic_SOURCES = make_driver_db_foomatic.c
+
+entry_DATA = foomatic.print
+entrydir = $(kde_datadir)/tdeprint/plugins