summaryrefslogtreecommitdiffstats
path: root/tdeprint/tools/escputil/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdeprint/tools/escputil/Makefile.am')
-rw-r--r--tdeprint/tools/escputil/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/tdeprint/tools/escputil/Makefile.am b/tdeprint/tools/escputil/Makefile.am
new file mode 100644
index 000000000..ac7620ef1
--- /dev/null
+++ b/tdeprint/tools/escputil/Makefile.am
@@ -0,0 +1,12 @@
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = tdeprint_tool_escputil.la
+tdeprint_tool_escputil_la_SOURCES = escpwidget.cpp
+tdeprint_tool_escputil_la_METASOURCES = AUTO
+tdeprint_tool_escputil_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+tdeprint_tool_escputil_la_LIBADD = $(LIB_KDEUI) $(LIB_QT) $(LIB_KDECORE)
+
+noinst_HEADERS = escpwidget.h
+
+service_DATA = escputil.desktop
+servicedir = $(kde_datadir)/tdeprint/tools