summaryrefslogtreecommitdiffstats
path: root/arts/modules/common/mcopclass/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2017-03-26 15:58:46 +0200
committerSlávek Banko <slavek.banko@axis.cz>2017-03-26 15:58:46 +0200
commit8b12682035e2ae92a29a9ce12abc5fbcf38b1192 (patch)
tree1cc5c3fe9ef3b23557fc4e9e507fd0d23d007160 /arts/modules/common/mcopclass/CMakeLists.txt
parent250d713ff809fa943f614459009d1160e269dcef (diff)
downloadtdemultimedia-8b12682035e2ae92a29a9ce12abc5fbcf38b1192.tar.gz
tdemultimedia-8b12682035e2ae92a29a9ce12abc5fbcf38b1192.zip
Initial cmake conversion
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'arts/modules/common/mcopclass/CMakeLists.txt')
-rw-r--r--arts/modules/common/mcopclass/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/arts/modules/common/mcopclass/CMakeLists.txt b/arts/modules/common/mcopclass/CMakeLists.txt
new file mode 100644
index 00000000..40d34d7a
--- /dev/null
+++ b/arts/modules/common/mcopclass/CMakeLists.txt
@@ -0,0 +1,27 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+install(
+ FILES
+ EffectRackGuiFactory.mcopclass
+ MixerGuiFactory.mcopclass
+ DESTINATION ${LIB_INSTALL_DIR}/mcop/Arts
+)
+
+install(
+ FILES
+ InstrumentItem.mcopclass
+ Container.mcopclass
+ MixerItem.mcopclass
+ EffectRackItem.mcopclass
+ InstrumentItemGuiFactory.mcopclass
+ DESTINATION ${LIB_INSTALL_DIR}/mcop/Arts/Environment
+)