summaryrefslogtreecommitdiffstats
path: root/arts/modules/effects/mcopclass/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2017-03-26 15:58:46 +0200
committerSlávek Banko <slavek.banko@axis.cz>2017-03-26 15:59:04 +0200
commitefcdd889254fc98314dd48854d50e90aa21e53c0 (patch)
tree5dc7034c23a5a18ca31d90225137f5eeaec809c4 /arts/modules/effects/mcopclass/CMakeLists.txt
parent25709e498d5832125f5f584bd10e3c66d05ec5ee (diff)
downloadtdemultimedia-efcdd889254fc98314dd48854d50e90aa21e53c0.tar.gz
tdemultimedia-efcdd889254fc98314dd48854d50e90aa21e53c0.zip
Initial cmake conversion
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 8b12682035e2ae92a29a9ce12abc5fbcf38b1192)
Diffstat (limited to 'arts/modules/effects/mcopclass/CMakeLists.txt')
-rw-r--r--arts/modules/effects/mcopclass/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/arts/modules/effects/mcopclass/CMakeLists.txt b/arts/modules/effects/mcopclass/CMakeLists.txt
new file mode 100644
index 00000000..17a2162a
--- /dev/null
+++ b/arts/modules/effects/mcopclass/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+install(
+ FILES
+ FiveBandMonoComplexEQ.mcopclass
+ FiveBandMonoComplexEQGuiFactory.mcopclass
+ MonoToStereo.mcopclass
+ StereoToMono.mcopclass
+ StereoBalance.mcopclass
+ StereoBalanceGuiFactory.mcopclass
+ Synth_VOICE_REMOVAL.mcopclass
+ VoiceRemovalGuiFactory.mcopclass
+ Synth_STEREO_COMPRESSOR.mcopclass
+ StereoCompressorGuiFactory.mcopclass
+ Synth_STEREO_PITCH_SHIFT.mcopclass
+ Synth_STEREO_PITCH_SHIFT_FFT.mcopclass
+ Synth_STEREO_FIR_EQUALIZER.mcopclass
+ StereoFirEqualizerGuiFactory.mcopclass
+ Synth_FREEVERB.mcopclass
+ FreeverbGuiFactory.mcopclass
+ Effect_WAVECAPTURE.mcopclass
+ StereoVolumeControlGui.mcopclass
+ StereoVolumeControlGuiFactory.mcopclass
+ DESTINATION ${LIB_INSTALL_DIR}/mcop/Arts
+)