summaryrefslogtreecommitdiffstats
path: root/arts/modules/synth/mcopclass/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2017-03-26 15:58:46 +0200
committerSlávek Banko <slavek.banko@axis.cz>2017-03-26 15:59:04 +0200
commitefcdd889254fc98314dd48854d50e90aa21e53c0 (patch)
tree5dc7034c23a5a18ca31d90225137f5eeaec809c4 /arts/modules/synth/mcopclass/CMakeLists.txt
parent25709e498d5832125f5f584bd10e3c66d05ec5ee (diff)
downloadtdemultimedia-efcdd889254fc98314dd48854d50e90aa21e53c0.tar.gz
tdemultimedia-efcdd889254fc98314dd48854d50e90aa21e53c0.zip
Initial cmake conversion
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 8b12682035e2ae92a29a9ce12abc5fbcf38b1192)
Diffstat (limited to 'arts/modules/synth/mcopclass/CMakeLists.txt')
-rw-r--r--arts/modules/synth/mcopclass/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/arts/modules/synth/mcopclass/CMakeLists.txt b/arts/modules/synth/mcopclass/CMakeLists.txt
new file mode 100644
index 00000000..fdda9cca
--- /dev/null
+++ b/arts/modules/synth/mcopclass/CMakeLists.txt
@@ -0,0 +1,49 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+install(
+ FILES
+ Synth_XFADE.mcopclass
+ Synth_AUTOPANNER.mcopclass
+ Synth_DELAY.mcopclass
+ Synth_CDELAY.mcopclass
+ Synth_ENVELOPE_ADSR.mcopclass
+ Synth_PSCALE.mcopclass
+ Synth_TREMOLO.mcopclass
+ Synth_FX_CFLANGER.mcopclass
+ Synth_COMPRESSOR.mcopclass
+ Synth_PITCH_SHIFT.mcopclass
+ Synth_PITCH_SHIFT_FFT.mcopclass
+ Synth_SHELVE_CUTOFF.mcopclass
+ Synth_BRICKWALL_LIMITER.mcopclass
+ Synth_STD_EQUALIZER.mcopclass
+ Synth_RC.mcopclass
+ Synth_MOOG_VCF.mcopclass
+ Synth_ATAN_SATURATE.mcopclass
+ Synth_FM_SOURCE.mcopclass
+ Synth_WAVE_TRI.mcopclass
+ Synth_NOISE.mcopclass
+ Synth_WAVE_SOFTSAW.mcopclass
+ Synth_WAVE_SQUARE.mcopclass
+ Synth_WAVE_PULSE.mcopclass
+ Synth_OSC.mcopclass
+ Synth_PLAY_PAT.mcopclass
+ Synth_CAPTURE_WAV.mcopclass
+ Synth_DIV.mcopclass
+ Synth_MIDI_TEST.mcopclass
+ Synth_SEQUENCE.mcopclass
+ Synth_SEQUENCE_FREQ.mcopclass
+ Synth_MIDI_DEBUG.mcopclass
+ Synth_DATA.mcopclass
+ Synth_DEBUG.mcopclass
+ Synth_NIL.mcopclass
+ DESTINATION ${LIB_INSTALL_DIR}/mcop/Arts
+)