summaryrefslogtreecommitdiffstats
path: root/kioslave/audiocd/plugins/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commite2de64d6f1beb9e492daf5b886e19933c1fa41dd (patch)
tree9047cf9e6b5c43878d5bf82660adae77ceee097a /kioslave/audiocd/plugins/Makefile.am
downloadtdemultimedia-e2de64d6f1beb9e492daf5b886e19933c1fa41dd.tar.gz
tdemultimedia-e2de64d6f1beb9e492daf5b886e19933c1fa41dd.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdemultimedia@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kioslave/audiocd/plugins/Makefile.am')
-rw-r--r--kioslave/audiocd/plugins/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kioslave/audiocd/plugins/Makefile.am b/kioslave/audiocd/plugins/Makefile.am
new file mode 100644
index 00000000..2dd4589c
--- /dev/null
+++ b/kioslave/audiocd/plugins/Makefile.am
@@ -0,0 +1,21 @@
+#if HAVE_VORBIS
+#AUDIOCD_PLUGINS_SUBDIR=vorbis
+#endif
+
+SUBDIRS = . wav vorbis lame flac
+
+INCLUDES = -I$(top_srcdir)/libkcddb $(all_includes)
+
+lib_LTLIBRARIES = libaudiocdplugins.la
+
+libaudiocdplugins_la_LIBADD = $(LIB_KDECORE) $(top_builddir)/libkcddb/libkcddb.la
+
+libaudiocdplugins_la_LDFLAGS = $(all_libraries) -version-info 1:0:0 -no-undefined
+
+libaudiocdplugins_la_SOURCES = audiocdencoder.cpp
+
+include_HEADERS = audiocdencoder.h
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kio_audiocd.pot
+