summaryrefslogtreecommitdiffstats
path: root/krec/mp3_export/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-30 00:57:03 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-30 00:57:05 +0200
commitff3f2006ce72b2edabc534188a4ad006e89b4f84 (patch)
treec81f41ffa6e329ddadd048e07b553af2154f5e16 /krec/mp3_export/CMakeLists.txt
parent9817ad52c6376ae54f5e4e4d11a31d958cc85faa (diff)
downloadtdemultimedia-ff3f2006ce72b2edabc534188a4ad006e89b4f84.tar.gz
tdemultimedia-ff3f2006ce72b2edabc534188a4ad006e89b4f84.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'krec/mp3_export/CMakeLists.txt')
-rw-r--r--krec/mp3_export/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/krec/mp3_export/CMakeLists.txt b/krec/mp3_export/CMakeLists.txt
index 13850c31..c0575e89 100644
--- a/krec/mp3_export/CMakeLists.txt
+++ b/krec/mp3_export/CMakeLists.txt
@@ -47,4 +47,8 @@ tde_add_kpart( libkrecexport_mp3 AUTOMOC
##### other data ################################
-install( FILES krec_exportmp3.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_creat_translated_desktop(
+ SOURCE krec_exportmp3.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/krec-desktops
+)