summaryrefslogtreecommitdiffstats
path: root/mpeglib/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-12-27 14:12:10 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-12-27 20:16:31 +0900
commit88cb1417b60deb6357228acb88f86f3f840bbb40 (patch)
tree03e358b506a152bb592c30cab089222a3e0fc0f1 /mpeglib/lib/CMakeLists.txt
parentdafa15cc2895d4b34f96be3f34766119a024296b (diff)
downloadtdemultimedia-88cb1417b60deb6357228acb88f86f3f840bbb40.tar.gz
tdemultimedia-88cb1417b60deb6357228acb88f86f3f840bbb40.zip
Replace pthread and dl linking with cmake-based variables
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 1bbc86f7b626b7754fba76d992b367e734991291)
Diffstat (limited to 'mpeglib/lib/CMakeLists.txt')
-rw-r--r--mpeglib/lib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/mpeglib/lib/CMakeLists.txt b/mpeglib/lib/CMakeLists.txt
index ad500d03..7b3dab41 100644
--- a/mpeglib/lib/CMakeLists.txt
+++ b/mpeglib/lib/CMakeLists.txt
@@ -63,7 +63,7 @@ tde_add_library( mpeg SHARED
mcop kmedia2_idl soundserver_idl artsflow_idl artsmodules-shared
X11 ${XEXT_LIBRARIES} m ${XV_LIBRARIES} ${DGA_LIBRARIES} ${XVIDMODE_LIBRARIES}
${CDPARANOIA_LIBRARIES} ${OGG_LIBRARIES} ${VORBIS_LIBRARIES} ${VORBISFILE_LIBRARIES}
- pthread
+ ${CMAKE_THREAD_LIBS_INIT}
DESTINATION ${LIB_INSTALL_DIR}
)