summaryrefslogtreecommitdiffstats
path: root/noatun/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-30 00:57:03 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-30 00:57:05 +0200
commitff3f2006ce72b2edabc534188a4ad006e89b4f84 (patch)
treec81f41ffa6e329ddadd048e07b553af2154f5e16 /noatun/CMakeLists.txt
parent9817ad52c6376ae54f5e4e4d11a31d958cc85faa (diff)
downloadtdemultimedia-ff3f2006ce72b2edabc534188a4ad006e89b4f84.tar.gz
tdemultimedia-ff3f2006ce72b2edabc534188a4ad006e89b4f84.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'noatun/CMakeLists.txt')
-rw-r--r--noatun/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/noatun/CMakeLists.txt b/noatun/CMakeLists.txt
index df9f15b4..dc2a6817 100644
--- a/noatun/CMakeLists.txt
+++ b/noatun/CMakeLists.txt
@@ -56,8 +56,13 @@ add_custom_target( noatun.api
##### other data ################################
-install( FILES noatun.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE noatun.desktop
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/noatun-desktops
+)
+
install( FILES noatun.upd DESTINATION ${DATA_INSTALL_DIR}/tdeconf_update )
+
install(
FILES
preset.dance preset.jazz preset.metal preset.trance preset.zero