summaryrefslogtreecommitdiffstats
path: root/noatun/modules/simple/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commite2de64d6f1beb9e492daf5b886e19933c1fa41dd (patch)
tree9047cf9e6b5c43878d5bf82660adae77ceee097a /noatun/modules/simple/Makefile.am
downloadtdemultimedia-e2de64d6f1beb9e492daf5b886e19933c1fa41dd.tar.gz
tdemultimedia-e2de64d6f1beb9e492daf5b886e19933c1fa41dd.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdemultimedia@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'noatun/modules/simple/Makefile.am')
-rw-r--r--noatun/modules/simple/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/noatun/modules/simple/Makefile.am b/noatun/modules/simple/Makefile.am
new file mode 100644
index 00000000..de5a7aa8
--- /dev/null
+++ b/noatun/modules/simple/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES= -I$(top_srcdir)/noatun/library -I$(kde_includes)/arts $(all_includes)
+
+kde_module_LTLIBRARIES = noatunsimple.la
+
+noatunsimple_la_SOURCES = propertiesdialog.ui noatunui.cpp userinterface.cpp
+noatunsimple_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+noatunsimple_la_LIBADD = $(top_builddir)/noatun/library/libnoatun.la \
+ $(top_builddir)/noatun/library/libnoatuncontrols.la \
+ -lkmedia2_idl -lsoundserver_idl -lartskde
+
+noatunsimple_la_METASOURCES = AUTO
+
+noinst_HEADERS = propertiesdialog.h userinterface.h
+
+noatun_modules_simple_DATA = simple.plugin simpleui.rc
+noatun_modules_simpledir = $(kde_datadir)/noatun