summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:32 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:32 -0600
commit793cf2dff35dffe3ec4c7b24252947dde758a1b2 (patch)
tree7d9972d99ed281a36418ae9f5fc128e3c951532c /tdefile-plugins/Makefile.am
parent04f764aaf273340e1d5811d4216dd8127cacc5db (diff)
downloadtdemultimedia-793cf2dff35dffe3ec4c7b24252947dde758a1b2.tar.gz
tdemultimedia-793cf2dff35dffe3ec4c7b24252947dde758a1b2.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdefile-plugins/Makefile.am')
-rw-r--r--tdefile-plugins/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tdefile-plugins/Makefile.am b/tdefile-plugins/Makefile.am
new file mode 100644
index 00000000..fc127f02
--- /dev/null
+++ b/tdefile-plugins/Makefile.am
@@ -0,0 +1,22 @@
+if include_ogg_SUBDIR
+KFILE_OGG_SUBDIR=ogg
+endif
+
+if include_flac_SUBDIR
+KFILE_FLAC_SUBDIR=flac
+endif
+
+if include_mp3_SUBDIR
+KFILE_MP3_SUBDIR=mp3
+endif
+
+if include_mpc_SUBDIR
+KFILE_MPC_SUBDIR=mpc
+endif
+
+if include_theora_SUBDIR
+KFILE_THEORA_SUBDIR=theora
+endif
+
+SUBDIRS=m3u $(KFILE_MP3_SUBDIR) $(KFILE_MPC_SUBDIR) au avi mpeg wav sid $(KFILE_OGG_SUBDIR) \
+ $(KFILE_FLAC_SUBDIR) $(KFILE_THEORA_SUBDIR)