summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/sid/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-30 00:57:03 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-30 01:05:29 +0200
commitd11ce98ed0b2a0508fcfbe8bb0f956e3f671ad0d (patch)
tree060933b7cc6b5aa928a37c4868330f58fb5b6294 /tdefile-plugins/sid/CMakeLists.txt
parent77d1049eb65f4d8bd24351c5c1a8d6344bf3ec62 (diff)
downloadtdemultimedia-d11ce98ed0b2a0508fcfbe8bb0f956e3f671ad0d.tar.gz
tdemultimedia-d11ce98ed0b2a0508fcfbe8bb0f956e3f671ad0d.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit ff3f2006ce72b2edabc534188a4ad006e89b4f84)
Diffstat (limited to 'tdefile-plugins/sid/CMakeLists.txt')
-rw-r--r--tdefile-plugins/sid/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tdefile-plugins/sid/CMakeLists.txt b/tdefile-plugins/sid/CMakeLists.txt
index 5802a35a..68c8f94a 100644
--- a/tdefile-plugins/sid/CMakeLists.txt
+++ b/tdefile-plugins/sid/CMakeLists.txt
@@ -35,4 +35,8 @@ tde_add_kpart( tdefile_sid AUTOMOC
##### other data ################################
-install( FILES tdefile_sid.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE tdefile_sid.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdefile-desktops
+)