summaryrefslogtreecommitdiffstats
path: root/tdeioslave/audiocd/plugins/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:32 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:32 -0600
commit793cf2dff35dffe3ec4c7b24252947dde758a1b2 (patch)
tree7d9972d99ed281a36418ae9f5fc128e3c951532c /tdeioslave/audiocd/plugins/Makefile.am
parent04f764aaf273340e1d5811d4216dd8127cacc5db (diff)
downloadtdemultimedia-793cf2dff35dffe3ec4c7b24252947dde758a1b2.tar.gz
tdemultimedia-793cf2dff35dffe3ec4c7b24252947dde758a1b2.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/audiocd/plugins/Makefile.am')
-rw-r--r--tdeioslave/audiocd/plugins/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/tdeioslave/audiocd/plugins/Makefile.am b/tdeioslave/audiocd/plugins/Makefile.am
new file mode 100644
index 00000000..fcee4e68
--- /dev/null
+++ b/tdeioslave/audiocd/plugins/Makefile.am
@@ -0,0 +1,21 @@
+#if HAVE_VORBIS
+#AUDIOCD_PLUGINS_SUBDIR=vorbis
+#endif
+
+SUBDIRS = . wav vorbis lame flac
+
+INCLUDES = -I$(top_srcdir)/libkcddb $(all_includes)
+
+lib_LTLIBRARIES = libaudiocdplugins.la
+
+libaudiocdplugins_la_LIBADD = $(LIB_TDECORE) $(top_builddir)/libkcddb/libkcddb.la
+
+libaudiocdplugins_la_LDFLAGS = $(all_libraries) -version-info 1:0:0 -no-undefined
+
+libaudiocdplugins_la_SOURCES = audiocdencoder.cpp
+
+include_HEADERS = audiocdencoder.h
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/tdeio_audiocd.pot
+