summaryrefslogtreecommitdiffstats
path: root/tdeioslave/audiocd/plugins/lame/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:32 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:32 -0600
commit793cf2dff35dffe3ec4c7b24252947dde758a1b2 (patch)
tree7d9972d99ed281a36418ae9f5fc128e3c951532c /tdeioslave/audiocd/plugins/lame/Makefile.am
parent04f764aaf273340e1d5811d4216dd8127cacc5db (diff)
downloadtdemultimedia-793cf2dff35dffe3ec4c7b24252947dde758a1b2.tar.gz
tdemultimedia-793cf2dff35dffe3ec4c7b24252947dde758a1b2.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/audiocd/plugins/lame/Makefile.am')
-rw-r--r--tdeioslave/audiocd/plugins/lame/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/tdeioslave/audiocd/plugins/lame/Makefile.am b/tdeioslave/audiocd/plugins/lame/Makefile.am
new file mode 100644
index 00000000..49ddddd9
--- /dev/null
+++ b/tdeioslave/audiocd/plugins/lame/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES = -I$(top_srcdir)/libkcddb -I$(srcdir)/.. $(taglib_includes) $(all_includes)
+
+kde_kcfg_DATA = audiocd_lame_encoder.kcfg
+
+kde_module_LTLIBRARIES = libaudiocd_encoder_lame.la
+
+libaudiocd_encoder_lame_la_SOURCES = audiocd_lame_encoder.kcfgc encoderlame.cpp encoderlameconfig.ui collectingprocess.cpp
+
+libaudiocd_encoder_lame_la_LIBADD = $(LIB_KIO) ../libaudiocdplugins.la
+
+libaudiocd_encoder_lame_la_LDFLAGS = -avoid-version -module -no-undefined $(taglib_libs) $(all_libraries)
+
+pluginsdir = $(kde_datadir)/audiocd/plugins
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/audiocd_encoder_lame.pot