summaryrefslogtreecommitdiffstats
path: root/arts/modules/synth/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'arts/modules/synth/Makefile.am')
-rw-r--r--arts/modules/synth/Makefile.am26
1 files changed, 13 insertions, 13 deletions
diff --git a/arts/modules/synth/Makefile.am b/arts/modules/synth/Makefile.am
index 520b33fe..211d973c 100644
--- a/arts/modules/synth/Makefile.am
+++ b/arts/modules/synth/Makefile.am
@@ -15,17 +15,17 @@ MCOP_INCLUDES= \
lib_LTLIBRARIES = libartsmodulessynth.la
-libartsmodulessynth_la_SOURCES = artsmodulessynth.cc \
- synth_xfade_impl.cc synth_autopanner_impl.cc synth_delay_impl.cc synth_cdelay_impl.cc \
- synth_envelope_adsr_impl.cc synth_pscale_impl.cc \
- synth_tremolo_impl.cc synth_fx_cflanger_impl.cc synth_compressor_impl.cc \
- synth_pitch_shift_impl.cc synth_pitch_shift_fft_impl.cc c_filter_stuff.c synth_shelve_cutoff_impl.cc synth_brickwall_limiter_impl.cc synth_std_equalizer_impl.cc synth_rc_impl.cc synth_moog_vcf_impl.cc synth_atan_saturate_impl.cc \
- synth_fm_source_impl.cc \
- synth_wave_tri_impl.cc synth_noise_impl.cc synth_wave_softsaw_impl.cc synth_wave_square_impl.cc synth_wave_pulse_impl.cc synth_osc_impl.cc synth_play_pat_impl.cc \
- synth_capture_wav_impl.cc \
- synth_midi_test_impl.cc synth_sequence_impl.cc synth_sequence_freq_impl.cc \
- synth_midi_debug_impl.cc objectcache_impl.cc synth_nil_impl.cc synth_debug_impl.cc synth_data_impl.cc \
- synth_div_impl.cc
+libartsmodulessynth_la_SOURCES = artsmodulessynth.cpp \
+ synth_xfade_impl.cpp synth_autopanner_impl.cpp synth_delay_impl.cpp synth_cdelay_impl.cpp \
+ synth_envelope_adsr_impl.cpp synth_pscale_impl.cpp \
+ synth_tremolo_impl.cpp synth_fx_cflanger_impl.cpp synth_compressor_impl.cpp \
+ synth_pitch_shift_impl.cpp synth_pitch_shift_fft_impl.cpp c_filter_stuff.c synth_shelve_cutoff_impl.cpp synth_brickwall_limiter_impl.cpp synth_std_equalizer_impl.cpp synth_rc_impl.cpp synth_moog_vcf_impl.cpp synth_atan_saturate_impl.cpp \
+ synth_fm_source_impl.cpp \
+ synth_wave_tri_impl.cpp synth_noise_impl.cpp synth_wave_softsaw_impl.cpp synth_wave_square_impl.cpp synth_wave_pulse_impl.cpp synth_osc_impl.cpp synth_play_pat_impl.cpp \
+ synth_capture_wav_impl.cpp \
+ synth_midi_test_impl.cpp synth_sequence_impl.cpp synth_sequence_freq_impl.cpp \
+ synth_midi_debug_impl.cpp objectcache_impl.cpp synth_nil_impl.cpp synth_debug_impl.cpp synth_data_impl.cpp \
+ synth_div_impl.cpp
libartsmodulessynth_la_COMPILE_FIRST = artsmodulessynth.h ../../midi/artsmidi.h
libartsmodulessynth_la_LIBADD = \
@@ -36,10 +36,10 @@ libartsmodulessynth_la_LIBADD = \
#libartsmodulessynth_la_LIBADD = $(top_builddir)/arts/gui/common/libartsgui_idl.la $(top_builddir)/arts/midi/libartsmidi_idl.la -lartsflow -lartsflow_idl -lmcop $(LIBDL) $(LIB_TDEUI) $(LIB_TDECORE)
libartsmodulessynth_la_LDFLAGS = $(all_libraries) -L$(arts_libraries) -lartsflow -lartsgsl -no-undefined
-artsmodulessynth.cc artsmodulessynth.h artsmodulessynth.mcoptype artsmodulessynth.mcopclass: $(srcdir)/artsmodulessynth.idl $(MCOPIDL)
+artsmodulessynth.cpp artsmodulessynth.h artsmodulessynth.mcoptype artsmodulessynth.mcopclass: $(srcdir)/artsmodulessynth.idl $(MCOPIDL)
$(MCOPIDL) -t $(MCOP_INCLUDES) $(srcdir)/artsmodulessynth.idl
-DISTCLEANFILES= artsmodulessynth.cc artsmodulessynth.h artsmodulessynth.mcop*
+DISTCLEANFILES= artsmodulessynth.cpp artsmodulessynth.h artsmodulessynth.mcop*
artsincludedir = $(includedir)/arts
artsinclude_HEADERS = artsmodulessynth.h artsmodulessynth.idl