summaryrefslogtreecommitdiffstats
path: root/noatun/modules/net/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'noatun/modules/net/Makefile.am')
-rw-r--r--noatun/modules/net/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/noatun/modules/net/Makefile.am b/noatun/modules/net/Makefile.am
new file mode 100644
index 00000000..9398a602
--- /dev/null
+++ b/noatun/modules/net/Makefile.am
@@ -0,0 +1,14 @@
+INCLUDES= -I$(top_srcdir)/noatun/library $(all_includes)
+kde_module_LTLIBRARIES = noatun_net.la
+
+noatun_net_la_SOURCES = net.cpp
+
+noatun_net_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatun_net_la_LIBADD = $(LIB_KFILE) $(top_builddir)/noatun/library/libnoatun.la
+
+noatun_net_la_METASOURCES = AUTO
+
+noinst_HEADERS = net.h
+
+noatun_modules_net_DATA = net.plugin
+noatun_modules_netdir = $(kde_datadir)/noatun