summaryrefslogtreecommitdiffstats
path: root/noatun/modules/voiceprint/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'noatun/modules/voiceprint/Makefile.am')
-rw-r--r--noatun/modules/voiceprint/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/noatun/modules/voiceprint/Makefile.am b/noatun/modules/voiceprint/Makefile.am
new file mode 100644
index 00000000..22c3f65c
--- /dev/null
+++ b/noatun/modules/voiceprint/Makefile.am
@@ -0,0 +1,14 @@
+INCLUDES= -I$(top_srcdir)/noatun/library $(all_includes)
+kde_module_LTLIBRARIES = noatun_voiceprint.la
+
+noatun_voiceprint_la_SOURCES = voiceprint.cpp prefs.cpp
+
+noatun_voiceprint_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatun_voiceprint_la_LIBADD = $(LIB_KFILE) $(top_builddir)/noatun/library/libnoatun.la -lm
+
+noatun_voiceprint_la_METASOURCES = AUTO
+
+noinst_HEADERS = voiceprint.h prefs.h
+
+noatun_modules_voiceprint_DATA = voiceprint.plugin
+noatun_modules_voiceprintdir = $(kde_datadir)/noatun