summaryrefslogtreecommitdiffstats
path: root/filesharing/advanced/kcm_sambaconf/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-11-22 18:23:21 +0100
committerSlávek Banko <slavek.banko@axis.cz>2012-11-22 18:25:27 +0100
commit6ab3b4d320a0c673f0f4ed091a94373e8d9a7875 (patch)
treedf03bd92b612028c7ebcfc1a0ac1a945cb415406 /filesharing/advanced/kcm_sambaconf/CMakeLists.txt
parent14f7445dfd828869ab53979b02304209eee0afdf (diff)
downloadtdenetwork-6ab3b4d320a0c673f0f4ed091a94373e8d9a7875.tar.gz
tdenetwork-6ab3b4d320a0c673f0f4ed091a94373e8d9a7875.zip
Fix cmake build: add dependencies for filesharing parallel build
Thanks to Fat-Zer
Diffstat (limited to 'filesharing/advanced/kcm_sambaconf/CMakeLists.txt')
-rw-r--r--filesharing/advanced/kcm_sambaconf/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/filesharing/advanced/kcm_sambaconf/CMakeLists.txt b/filesharing/advanced/kcm_sambaconf/CMakeLists.txt
index 41723ee5..d466124e 100644
--- a/filesharing/advanced/kcm_sambaconf/CMakeLists.txt
+++ b/filesharing/advanced/kcm_sambaconf/CMakeLists.txt
@@ -37,6 +37,24 @@ tde_add_library( filesharesamba STATIC_PIC AUTOMOC
filemodedlgimpl.cpp smbpasswdfile.cpp passwd.cpp hiddenfileview.cpp
dictmanager.cpp qmultichecklistitem.cpp smbconfconfigwidget.cpp
linuxpermissionchecker.cpp expertuserdlg.ui
+ DEPENDENCIES filesharesamba_generate_headers
+)
+
+# Those headers are also required by target in another subdirectory.
+# So we have to add such target for our generated header files to avoid
+# race conditions.
+# SEE cmake FAQ: http://www.cmake.org/Wiki/CMake_FAQ
+#
+add_custom_target( filesharesamba_generate_headers
+ DEPENDS
+ ${CMAKE_CURRENT_BINARY_DIR}/share.h
+ ${CMAKE_CURRENT_BINARY_DIR}/share.h
+ ${CMAKE_CURRENT_BINARY_DIR}/socketoptionsdlg.h
+ ${CMAKE_CURRENT_BINARY_DIR}/userselectdlg.h
+ ${CMAKE_CURRENT_BINARY_DIR}/groupselectdlg.h
+ ${CMAKE_CURRENT_BINARY_DIR}/usertab.h
+ ${CMAKE_CURRENT_BINARY_DIR}/filemodedlg.h
+ ${CMAKE_CURRENT_BINARY_DIR}/expertuserdlg.h
)