summaryrefslogtreecommitdiffstats
path: root/filesharing/advanced/propsdlgplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-11-22 18:23:21 +0100
committerSlávek Banko <slavek.banko@axis.cz>2012-11-22 18:25:27 +0100
commit6ab3b4d320a0c673f0f4ed091a94373e8d9a7875 (patch)
treedf03bd92b612028c7ebcfc1a0ac1a945cb415406 /filesharing/advanced/propsdlgplugin/CMakeLists.txt
parent14f7445dfd828869ab53979b02304209eee0afdf (diff)
downloadtdenetwork-6ab3b4d320a0c673f0f4ed091a94373e8d9a7875.tar.gz
tdenetwork-6ab3b4d320a0c673f0f4ed091a94373e8d9a7875.zip
Fix cmake build: add dependencies for filesharing parallel build
Thanks to Fat-Zer
Diffstat (limited to 'filesharing/advanced/propsdlgplugin/CMakeLists.txt')
-rw-r--r--filesharing/advanced/propsdlgplugin/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/filesharing/advanced/propsdlgplugin/CMakeLists.txt b/filesharing/advanced/propsdlgplugin/CMakeLists.txt
index 26d94f56..bd96ae62 100644
--- a/filesharing/advanced/propsdlgplugin/CMakeLists.txt
+++ b/filesharing/advanced/propsdlgplugin/CMakeLists.txt
@@ -11,7 +11,8 @@
include_directories(
${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_CURRENT_BINARY_DIR}/../kcm_sambaconf
+ ${CMAKE_BINARY_DIR}/filesharing/advanced/kcm_sambaconf
+ ${CMAKE_SOURCE_DIR}/filesharing/advanced/kcm_sambaconf
${TDE_INCLUDE_DIR}
${TQT_INCLUDE_DIRS}
)
@@ -32,7 +33,7 @@ install( FILES
tde_add_library( propsdlgplugin_common STATIC_PIC AUTOMOC
SOURCES propertiespage.cpp propertiespagegui.ui
- DEPENDENCIES filesharesamba
+ DEPENDENCIES filesharesamba_generate_headers
)