summaryrefslogtreecommitdiffstats
path: root/kdict/applet/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-08 22:39:20 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-09 13:04:01 +0200
commita94da7081d4567ba19782d6efea3aeb4af4d67ef (patch)
treef57b626ceac36667c35a04b8ddbdb57a903ef702 /kdict/applet/CMakeLists.txt
parent2810d16800c936ed93bf81df2ca0904d19490b96 (diff)
downloadtdenetwork-a94da7081d4567ba19782d6efea3aeb4af4d67ef.tar.gz
tdenetwork-a94da7081d4567ba19782d6efea3aeb4af4d67ef.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit d36d9267539f12fdaa5a0dd18f6285e4a636e1ac)
Diffstat (limited to 'kdict/applet/CMakeLists.txt')
-rw-r--r--kdict/applet/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/kdict/applet/CMakeLists.txt b/kdict/applet/CMakeLists.txt
index ad2d6b7d..2b702285 100644
--- a/kdict/applet/CMakeLists.txt
+++ b/kdict/applet/CMakeLists.txt
@@ -22,9 +22,11 @@ link_directories(
##### other data ################################
-install( FILES
- kdictapplet.desktop
- DESTINATION ${DATA_INSTALL_DIR}/kicker/applets )
+tde_create_translated_desktop(
+ SOURCE kdictapplet.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kicker/applets
+ PO_DIR kdict-desktops
+)
##### kdict_panelapplet (module) ################