summaryrefslogtreecommitdiffstats
path: root/kopete/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-05-22 20:12:04 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-05-22 20:12:04 +0000
commitac87680632b4fb6582d1391b042eff7f0305c0a2 (patch)
treebfeee57d104a1bbc7c387d35190fa55d692115b7 /kopete/CMakeLists.txt
parentaca844682f86c04f6b67b23de2a820fb0c63a32e (diff)
downloadtdenetwork-ac87680632b4fb6582d1391b042eff7f0305c0a2.tar.gz
tdenetwork-ac87680632b4fb6582d1391b042eff7f0305c0a2.zip
[kdenetwork/kopete] added cmake support
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1233119 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kopete/CMakeLists.txt')
-rw-r--r--kopete/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/kopete/CMakeLists.txt b/kopete/CMakeLists.txt
new file mode 100644
index 00000000..f04465a7
--- /dev/null
+++ b/kopete/CMakeLists.txt
@@ -0,0 +1,24 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+# NOTE some files was renamed:
+# kopetemessagemanager.h -> kopetechatsession.h
+# kopetemessagemanagerfactory.h -> kopetechatsessionmanager.h
+
+include( ConfigureChecks.cmake )
+
+add_subdirectory( libkopete )
+add_subdirectory( kopete )
+add_subdirectory( protocols )
+add_subdirectory( plugins )
+add_subdirectory( icons )
+add_subdirectory( sounds )
+add_subdirectory( styles )