summaryrefslogtreecommitdiffstats
path: root/kopete/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /kopete/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kopete/Makefile.am')
-rw-r--r--kopete/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kopete/Makefile.am b/kopete/Makefile.am
new file mode 100644
index 00000000..9532f16b
--- /dev/null
+++ b/kopete/Makefile.am
@@ -0,0 +1,22 @@
+SUBDIRS = libkopete kopete protocols plugins icons sounds styles
+
+api:
+ $(mkinstalldirs) $(top_builddir)/kopete/apidocs/libkopete
+ if test ! -x $(top_builddir)/kopete/apidocs/common; then \
+ $(LN_S) $(kde_libs_htmldir)/en/common $(top_builddir)/kopete/apidocs/common; \
+ fi
+ doxygen $(top_srcdir)/kopete/kopete.api
+
+
+messages:
+ $(EXTRACTRC) --context="Translators: The %FOO% placeholders are variables that are substituted in the code, please leave them untranslated" --tag-group=none --tag kopete-i18n styles/*.xsl > xml_doc.cpp
+ $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc | egrep -v '(libkopete/compat|protocols/testbed)'` > rc.cpp
+ LIST=`find . -name \*.h -o -name \*.cpp -o -name \*.c | egrep -v '(libkopete/compat|protocols/testbed)'`; \
+ if test -n "$$LIST"; then \
+ $(XGETTEXT) $$LIST -o $(podir)/kopete.pot; \
+ fi
+ -rm xml_doc.cpp
+
+
+DOXYGEN_EMPTY = YES
+include $(top_srcdir)/admin/Doxyfile.am