summaryrefslogtreecommitdiffstats
path: root/kopete/plugins/alias/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-18 10:52:13 -0600
committerSlávek Banko <slavek.banko@axis.cz>2012-08-05 19:16:15 +0200
commit5691aad400562d215e6234e3d31eb0a865effa3c (patch)
tree5114cb7316eda86fce10f4609e7dbc7836846ee8 /kopete/plugins/alias/Makefile.am
parent49deb564a46581cf305a60b7da2f4949efa9a757 (diff)
downloadtdenetwork-5691aad400562d215e6234e3d31eb0a865effa3c.tar.gz
tdenetwork-5691aad400562d215e6234e3d31eb0a865effa3c.zip
Update kdenetwork Autotools for new DSO linkage style
(cherry picked from commit d81f0e49aa19d9a3b627e140306abb10e3b26026)
Diffstat (limited to 'kopete/plugins/alias/Makefile.am')
-rw-r--r--kopete/plugins/alias/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/kopete/plugins/alias/Makefile.am b/kopete/plugins/alias/Makefile.am
index d295e0cc..26c871d0 100644
--- a/kopete/plugins/alias/Makefile.am
+++ b/kopete/plugins/alias/Makefile.am
@@ -4,11 +4,11 @@ AM_CPPFLAGS = $(KOPETE_INCLUDES) $(all_includes)
kde_module_LTLIBRARIES = kopete_alias.la kcm_kopete_alias.la
kopete_alias_la_SOURCES = aliasplugin.cpp
-kopete_alias_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries)
+kopete_alias_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor
kopete_alias_la_LIBADD = ../../libkopete/libkopete.la
kcm_kopete_alias_la_SOURCES = aliaspreferences.cpp aliasdialogbase.ui aliasdialog.ui editaliasdialog.cpp
-kcm_kopete_alias_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries)
+kcm_kopete_alias_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor
kcm_kopete_alias_la_LIBADD = $(LIB_KOPETECOMPAT) $(LIB_KUTILS) ../../libkopete/libkopete.la
service_DATA = kopete_alias.desktop