summaryrefslogtreecommitdiffstats
path: root/kopete/plugins/cryptography/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-18 10:52:13 -0600
committerSlávek Banko <slavek.banko@axis.cz>2012-08-05 19:16:15 +0200
commit5691aad400562d215e6234e3d31eb0a865effa3c (patch)
tree5114cb7316eda86fce10f4609e7dbc7836846ee8 /kopete/plugins/cryptography/Makefile.am
parent49deb564a46581cf305a60b7da2f4949efa9a757 (diff)
downloadtdenetwork-5691aad400562d215e6234e3d31eb0a865effa3c.tar.gz
tdenetwork-5691aad400562d215e6234e3d31eb0a865effa3c.zip
Update kdenetwork Autotools for new DSO linkage style
(cherry picked from commit d81f0e49aa19d9a3b627e140306abb10e3b26026)
Diffstat (limited to 'kopete/plugins/cryptography/Makefile.am')
-rw-r--r--kopete/plugins/cryptography/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/kopete/plugins/cryptography/Makefile.am b/kopete/plugins/cryptography/Makefile.am
index bbcaca2c..6b20a088 100644
--- a/kopete/plugins/cryptography/Makefile.am
+++ b/kopete/plugins/cryptography/Makefile.am
@@ -7,11 +7,11 @@ AM_CPPFLAGS = $(KOPETE_INCLUDES) $(all_includes)
kde_module_LTLIBRARIES = kopete_cryptography.la kcm_kopete_cryptography.la
kopete_cryptography_la_SOURCES = cryptographyplugin.cpp kgpginterface.cpp cryptographyguiclient.cpp cryptographyselectuserkey.cpp cryptographyuserkey_ui.ui popuppublic.cpp kgpgselkey.cpp
-kopete_cryptography_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries)
+kopete_cryptography_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor
kopete_cryptography_la_LIBADD = ../../libkopete/libkopete.la
kcm_kopete_cryptography_la_SOURCES = cryptographypreferences.cpp cryptographyprefsbase.ui kgpgselkey.cpp
-kcm_kopete_cryptography_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries)
+kcm_kopete_cryptography_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor
kcm_kopete_cryptography_la_LIBADD = ../../libkopete/libkopete.la $(LIB_KUTILS)
service_DATA = kopete_cryptography.desktop