summaryrefslogtreecommitdiffstats
path: root/kopete/plugins/highlight/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-08 22:39:20 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-08 22:39:20 +0200
commitd36d9267539f12fdaa5a0dd18f6285e4a636e1ac (patch)
tree65966d4e78c0529e0e56f8586a7d9c2ae530d336 /kopete/plugins/highlight/CMakeLists.txt
parent54888da0ae983555ec963c52007c50d49b3c66af (diff)
downloadtdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.tar.gz
tdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kopete/plugins/highlight/CMakeLists.txt')
-rw-r--r--kopete/plugins/highlight/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/kopete/plugins/highlight/CMakeLists.txt b/kopete/plugins/highlight/CMakeLists.txt
index 0b92404a..8c24d422 100644
--- a/kopete/plugins/highlight/CMakeLists.txt
+++ b/kopete/plugins/highlight/CMakeLists.txt
@@ -27,8 +27,17 @@ link_directories(
##### other data ################################
-install( FILES kopete_highlight.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
-install( FILES kopete_highlight_config.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tdeconfiguredialog )
+tde_create_translated_desktop(
+ SOURCE kopete_highlight.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR kopete-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE kopete_highlight_config.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/tdeconfiguredialog
+ PO_DIR kopete-desktops
+)
##### kopete_highlight (module) #################