summaryrefslogtreecommitdiffstats
path: root/kopete/plugins/netmeeting/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2014-03-29 00:54:51 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2014-03-29 00:54:51 +0900
commit0486034738b850c210b1389a8c3ae51a6b9fad23 (patch)
treeb1e3a4dbf9673b5e0031e8225e88f5dd490585a5 /kopete/plugins/netmeeting/CMakeLists.txt
parent4bd7620e88d450995b78c201f9e7d9181f62ea6a (diff)
downloadtdenetwork-0486034738b850c210b1389a8c3ae51a6b9fad23.tar.gz
tdenetwork-0486034738b850c210b1389a8c3ae51a6b9fad23.zip
Removed MSN support across Kopete by removing the MSN protocol and the netmeeting plugin.
This resolves bug 1547.
Diffstat (limited to 'kopete/plugins/netmeeting/CMakeLists.txt')
-rw-r--r--kopete/plugins/netmeeting/CMakeLists.txt56
1 files changed, 0 insertions, 56 deletions
diff --git a/kopete/plugins/netmeeting/CMakeLists.txt b/kopete/plugins/netmeeting/CMakeLists.txt
deleted file mode 100644
index dfda84e3..00000000
--- a/kopete/plugins/netmeeting/CMakeLists.txt
+++ /dev/null
@@ -1,56 +0,0 @@
-#################################################
-#
-# (C) 2010-2011 Serghei Amelian
-# serghei (DOT) amelian (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
-
-if( NOT BUILD_KOPETE_PROTOCOL_MSN )
- tde_message_fatal( "netmeeting plugin needs msn protocol.\n Add -DBUILD_KOPETE_PROTOCOL_MSN=ON to cmake flags." )
-endif( )
-
-include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_BINARY_DIR}
- ${CMAKE_SOURCE_DIR}/kopete/libkopete
- ${CMAKE_SOURCE_DIR}/kopete/libkopete/ui
- ${CMAKE_SOURCE_DIR}/kopete/protocols/msn
- ${TDE_INCLUDE_DIR}
- ${TQT_INCLUDE_DIRS}
-)
-
-link_directories(
- ${TQT_LIBRARY_DIRS}
-)
-
-
-##### other data ################################
-
-install( FILES kopete_netmeeting.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
-install( FILES kopete_netmeeting_config.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tdeconfiguredialog )
-install( FILES netmeetingchatui.rc DESTINATION ${DATA_INSTALL_DIR}/kopete_netmeeting )
-
-
-##### kopete_netmeeting (module) ################
-
-tde_add_kpart( kopete_netmeeting AUTOMOC
- SOURCES
- netmeetingplugin.cpp netmeetinginvitation.cpp
- netmeetingguiclient.cpp
- LINK kopete_msn_shared-shared kopete-shared
- DESTINATION ${PLUGIN_INSTALL_DIR}
-)
-
-
-##### kcm_kopete_netmeeting (module) ############
-
-tde_add_kpart( kcm_kopete_netmeeting AUTOMOC
- SOURCES
- netmeetingprefs_ui.ui netmeetingpreferences.cpp
- LINK tdeutils-shared
- DESTINATION ${PLUGIN_INSTALL_DIR}
-)