summaryrefslogtreecommitdiffstats
path: root/kopete/plugins/otr/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2021-06-28 16:13:49 +0200
committergregory guy <gregory-tde@laposte.net>2021-07-02 17:30:02 +0200
commitd0e4d47caed252840a0f9986a1a18ab7bf451ddb (patch)
tree939dabe4b69e2bf0c14fc93ee3d5f093f6d77565 /kopete/plugins/otr/CMakeLists.txt
parent7a3a7896b3c96bee076ed0da65d10eec7fc06b85 (diff)
downloadtdenetwork-feat/add_kopete-otr_plugin.tar.gz
tdenetwork-feat/add_kopete-otr_plugin.zip
Add kopete-otr plugin to kopete.feat/add_kopete-otr_plugin
Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'kopete/plugins/otr/CMakeLists.txt')
-rw-r--r--kopete/plugins/otr/CMakeLists.txt125
1 files changed, 125 insertions, 0 deletions
diff --git a/kopete/plugins/otr/CMakeLists.txt b/kopete/plugins/otr/CMakeLists.txt
new file mode 100644
index 00000000..8c45e5c3
--- /dev/null
+++ b/kopete/plugins/otr/CMakeLists.txt
@@ -0,0 +1,125 @@
+add_subdirectory( pics )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/src
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${LIBOTR_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}/kopete
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete/ui
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### kotr_kcfgc (static)
+
+tde_add_library( kotr_kcfgc STATIC_PIC AUTOMOC
+
+ SOURCES
+ kopete_otr.kcfgc
+)
+
+
+##### kotr (shared)
+
+tde_add_library( kotr SHARED AUTOMOC
+
+ SOURCES
+ otrplugin.cpp
+ otrguiclient.cpp
+ otrlchatinterface.cpp
+ otrlconfinterface.cpp
+ privkeypopup.cpp
+ privkeypopupui.ui
+ smppopup.cpp
+ smppopupui.ui
+ verifypopup.cpp
+ verifypopupui.ui
+
+ LINK
+ kotr_kcfgc-static
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+ kopete-shared
+ ${LIBOTR_LIBRARIES}
+
+ VERSION 0.0.0
+
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+
+##### kcm_kopete_otr (kpart)
+
+tde_add_kpart( kcm_kopete_otr AUTOMOC
+
+ SOURCES
+ otrpreferences.cpp
+ otrprefs.ui
+ LINK
+ kotr_kcfgc-static
+ kotr-shared
+ tdecore-shared
+ tdeui-shared
+ tdehtml-shared
+ kopete-shared
+ ${LIBOTR_LIBRARIES}
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### kopete_otr (kpart)
+
+tde_add_kpart( kopete_otr AUTOMOC
+
+ SOURCES
+ otrplugin-factory.cpp
+
+ LINK
+ kotr-shared
+ tdecore-shared
+ tdeui-shared
+ tdehtml-shared
+ kopete-shared
+ ${LIBOTR_LIBRARIES}
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES otrchatui.rc otrui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kopete_otr
+)
+
+install(
+ FILES kopete_otr.kcfg
+ DESTINATION ${KCFG_INSTALL_DIR}
+)
+
+
+#### desktop files
+
+tde_create_translated_desktop(
+ SOURCE kopete_otr.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR kopete_otr-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE kopete_otr_config.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/tdeconfiguredialog
+ PO_DIR kopete_otr-desktops
+)