summaryrefslogtreecommitdiffstats
path: root/kopete/plugins/statistics/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /kopete/plugins/statistics/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kopete/plugins/statistics/Makefile.am')
-rw-r--r--kopete/plugins/statistics/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kopete/plugins/statistics/Makefile.am b/kopete/plugins/statistics/Makefile.am
new file mode 100644
index 00000000..b6aa7812
--- /dev/null
+++ b/kopete/plugins/statistics/Makefile.am
@@ -0,0 +1,21 @@
+METASOURCES = AUTO
+
+INCLUDES = $(KOPETE_INCLUDES) $(all_includes)
+
+SUBDIRS = sqlite
+
+kde_module_LTLIBRARIES = kopete_statistics.la
+
+kopete_statistics_la_SOURCES = statisticsplugin.cpp statisticsdb.cpp statisticsdialog.cpp statisticswidget.ui statisticscontact.cpp statisticsdcopiface.skel
+
+kopete_statistics_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries)
+kopete_statistics_la_LIBADD = ../../libkopete/libkopete.la sqlite/libsqlite.la
+
+service_DATA = kopete_statistics.desktop
+servicedir = $(kde_servicesdir)
+
+mydatadir = $(kde_datadir)/kopete_statistics
+mydata_DATA = statisticsui.rc
+
+mydatadirimagesdir = $(kde_datadir)/kopete/pics/statistics
+mydatadirimages_DATA = images/blue.png images/navy.png images/black.png images/gray.png