summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/jabber/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-01-06 19:41:48 +0100
committerSlávek Banko <slavek.banko@axis.cz>2020-02-04 18:34:36 +0100
commitfa2cb167910bd9a801318b24a915733dae18c6e2 (patch)
tree674ca4e9491c089d6c189ffe2b8b50531af0035e /kopete/protocols/jabber/CMakeLists.txt
parentda681e86b1a185f6acb87e496d82c310095a7a6f (diff)
downloadtdenetwork-fa2cb167910bd9a801318b24a915733dae18c6e2.tar.gz
tdenetwork-fa2cb167910bd9a801318b24a915733dae18c6e2.zip
kopete: Added ability to build with shared tqca library.
QCA files renamed to TQCA to match tqca library. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 1037d386233764a3fd46c8e18699c874520d6d9e)
Diffstat (limited to 'kopete/protocols/jabber/CMakeLists.txt')
-rw-r--r--kopete/protocols/jabber/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/kopete/protocols/jabber/CMakeLists.txt b/kopete/protocols/jabber/CMakeLists.txt
index 61202e95..50a5089a 100644
--- a/kopete/protocols/jabber/CMakeLists.txt
+++ b/kopete/protocols/jabber/CMakeLists.txt
@@ -9,6 +9,11 @@
#
#################################################
+if( NOT TQCA_FOUND )
+ set( TQCA_INCLUDE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/libiris/qca/src )
+ set( TQCA_LIBRARIES "tqca-static" )
+endif( )
+
add_subdirectory( ui )
add_subdirectory( icons )
add_subdirectory( libiris )
@@ -34,7 +39,6 @@ include_directories(
${CMAKE_CURRENT_SOURCE_DIR}/libiris/iris/include
${CMAKE_CURRENT_SOURCE_DIR}/libiris/iris/jabber
${CMAKE_CURRENT_SOURCE_DIR}/libiris/iris/xmpp-im
- ${CMAKE_CURRENT_SOURCE_DIR}/libiris/qca/src
${CMAKE_CURRENT_SOURCE_DIR}/libiris/cutestuff/util
${CMAKE_CURRENT_SOURCE_DIR}/libiris/cutestuff/network
${CMAKE_CURRENT_SOURCE_DIR}/ui
@@ -44,6 +48,7 @@ include_directories(
${CMAKE_BINARY_DIR}
${TDE_INCLUDE_DIR}
${TQT_INCLUDE_DIRS}
+ ${TQCA_INCLUDE_DIR}
)
link_directories(
@@ -79,7 +84,7 @@ tde_add_kpart( kopete_jabber AUTOMOC
LINK
jabberclient-static kopetejabberui-static
iris_jabber-static iris_xmpp_core-static iris_xmpp_im-static iris-static
- qca-static cutestuff_network-static cutestuff_util-static ${JINGLE_LIBRARIES}
+ ${TQCA_LIBRARIES} cutestuff_network-static cutestuff_util-static ${JINGLE_LIBRARIES}
kopete-shared idn
DESTINATION ${PLUGIN_INSTALL_DIR}
)