summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/meanwhile/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /kopete/protocols/meanwhile/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kopete/protocols/meanwhile/Makefile.am')
-rw-r--r--kopete/protocols/meanwhile/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/kopete/protocols/meanwhile/Makefile.am b/kopete/protocols/meanwhile/Makefile.am
new file mode 100644
index 00000000..e161fac3
--- /dev/null
+++ b/kopete/protocols/meanwhile/Makefile.am
@@ -0,0 +1,37 @@
+METASOURCES = AUTO
+SUBDIRS = ui icons
+
+AM_CPPFLAGS = $(KOPETE_INCLUDES) \
+ -I$(srcdir)/ui \
+ -I./ui \
+ $(all_includes) \
+ $(MEANWHILE_CFLAGS)
+
+noinst_HEADERS = \
+ meanwhileprotocol.h \
+ meanwhileaddcontactpage.h \
+ meanwhileeditaccountwidget.h \
+ meanwhileaccount.h \
+ meanwhilecontact.h \
+ meanwhilesession.h \
+ meanwhileplugin.h
+
+kde_module_LTLIBRARIES = kopete_meanwhile.la
+
+kopete_meanwhile_la_SOURCES = \
+ meanwhileprotocol.cpp \
+ meanwhileaddcontactpage.cpp \
+ meanwhileeditaccountwidget.cpp \
+ meanwhileaccount.cpp \
+ meanwhilecontact.cpp \
+ meanwhilesession.cpp \
+ meanwhileplugin.cpp
+
+kopete_meanwhile_la_LDFLAGS = -no-undefined -module \
+ $(KDE_PLUGIN) $(all_libraries)
+
+kopete_meanwhile_la_LIBADD = $(top_builddir)/kopete/libkopete/libkopete.la \
+ ui/libkopetemeanwhileui.la $(MEANWHILE_LIBS)
+
+service_DATA = kopete_meanwhile.desktop
+servicedir= $(kde_servicesdir)