summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/msn/Makefile.am
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2014-03-29 00:54:51 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2014-03-29 00:54:51 +0900
commit0486034738b850c210b1389a8c3ae51a6b9fad23 (patch)
treeb1e3a4dbf9673b5e0031e8225e88f5dd490585a5 /kopete/protocols/msn/Makefile.am
parent4bd7620e88d450995b78c201f9e7d9181f62ea6a (diff)
downloadtdenetwork-0486034738b850c210b1389a8c3ae51a6b9fad23.tar.gz
tdenetwork-0486034738b850c210b1389a8c3ae51a6b9fad23.zip
Removed MSN support across Kopete by removing the MSN protocol and the netmeeting plugin.
This resolves bug 1547.
Diffstat (limited to 'kopete/protocols/msn/Makefile.am')
-rw-r--r--kopete/protocols/msn/Makefile.am47
1 files changed, 0 insertions, 47 deletions
diff --git a/kopete/protocols/msn/Makefile.am b/kopete/protocols/msn/Makefile.am
deleted file mode 100644
index 5248d295..00000000
--- a/kopete/protocols/msn/Makefile.am
+++ /dev/null
@@ -1,47 +0,0 @@
-if include_msn_webcam
-WEBCAM = webcam
-WEBCAM_LIBMINICWRAPPER = webcam/libmimicwrapper.la
-endif
-
-KDE_OPTIONS = nofinal
-METASOURCES = AUTO
-SUBDIRS = ui $(WEBCAM) . icons config
-AM_CPPFLAGS = -Iui \
- -I$(srcdir)/webcam \
- -I$(srcdir)/ui \
- $(KOPETE_INCLUDES) \
- -I$(top_srcdir)/kopete/libkopete/private \
- $(all_includes)
-
-kde_module_LTLIBRARIES = kopete_msn.la
-lib_LTLIBRARIES = libkopete_msn_shared.la
-
-CLEANFILES = dummy.cpp
-
-libkopete_msn_shared_la_SOURCES = msnprotocol.cpp msnaccount.cpp \
- msnaddcontactpage.cpp msncontact.cpp msnsocket.cpp msnchatsession.cpp msndebugrawcmddlg.cpp \
- msnnotifysocket.cpp msnswitchboardsocket.cpp msnfiletransfersocket.cpp msninvitation.cpp \
- sha1.cpp msnsecureloginhandler.cpp msnchallengehandler.cpp dispatcher.cpp \
- p2p.cpp messageformatter.cpp incomingtransfer.cpp outgoingtransfer.cpp \
- webcam.cpp
-
-libkopete_msn_shared_la_LIBADD = ./ui/libkopetemsnui.la ../../libkopete/libkopete.la $(WEBCAM_LIBMINICWRAPPER) ../../libkopete/avdevice/libkopete_videodevice.la $(LIB_TDEIO)
-libkopete_msn_shared_la_LDFLAGS = -version-info 0:0:0 -no-undefined $(all_libraries) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor -lkopete_videodevice -L../../libkopete/avdevice/
-
-kopete_msn_la_SOURCES = dummy.cpp webcam.cpp
-kopete_msn_la_LIBADD = libkopete_msn_shared.la
-
-kopete_msn_la_LDFLAGS = -no-undefined -module $(KDE_PLUGIN) $(all_libraries) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor -lkopete_videodevice -L../../libkopete/avdevice/
-
-dummy.cpp: $(srcdir)/Makefile.am
- echo '#include "kdemacros.h"' > $@
- echo 'extern "C" KDE_EXPORT void *init_libkopete_msn_shared();' >> $@
- echo 'extern "C" KDE_EXPORT void *init_kopete_msn() { return init_libkopete_msn_shared(); }' >> $@
-
-service_DATA = kopete_msn.desktop
-servicedir = $(kde_servicesdir)
-
-mydatadir = $(kde_datadir)/kopete_msn
-mydata_DATA = msnchatui.rc
-noinst_HEADERS = p2p.h dispatcher.h messageformatter.h incomingtransfer.h \
- outgoingtransfer.h webcam.h