summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/msn/webcam/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-12-11 01:41:26 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-12-11 19:36:33 +0100
commit7542bb6bd597400167da57dc43dd37ff85a6e173 (patch)
treec8ba8ffc7ff08af3f3f3478f6ee98bf0fd5b7bb1 /kopete/protocols/msn/webcam/CMakeLists.txt
parentfac887803df710a5ca534e0b79a5a274461e6697 (diff)
downloadtdenetwork-7542bb6bd597400167da57dc43dd37ff85a6e173.tar.gz
tdenetwork-7542bb6bd597400167da57dc43dd37ff85a6e173.zip
kopete: Restore the MSN protocol because a replacement MSN server was created.
This reverts commits 0486034738 - 2d5f9c55da and f6fd4ab6c0. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 73f00336178a9f312bac2992649120d462e0ac2d)
Diffstat (limited to 'kopete/protocols/msn/webcam/CMakeLists.txt')
-rw-r--r--kopete/protocols/msn/webcam/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/kopete/protocols/msn/webcam/CMakeLists.txt b/kopete/protocols/msn/webcam/CMakeLists.txt
new file mode 100644
index 00000000..aafa2d94
--- /dev/null
+++ b/kopete/protocols/msn/webcam/CMakeLists.txt
@@ -0,0 +1,28 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( libmimic )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${GLIB2_INCLUDE_DIRS}
+)
+
+
+##### mimicwrapper (static) #####################
+
+tde_add_library( mimicwrapper STATIC_PIC AUTOMOC
+ SOURCES mimicwrapper.cpp msnwebcamdialog.cpp
+ LINK mimic-static
+)