summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/oscar/icq/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /kopete/protocols/oscar/icq/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kopete/protocols/oscar/icq/Makefile.am')
-rw-r--r--kopete/protocols/oscar/icq/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kopete/protocols/oscar/icq/Makefile.am b/kopete/protocols/oscar/icq/Makefile.am
new file mode 100644
index 00000000..defadf37
--- /dev/null
+++ b/kopete/protocols/oscar/icq/Makefile.am
@@ -0,0 +1,22 @@
+SUBDIRS = ui .
+METASOURCES = AUTO
+AM_CPPFLAGS = -I$(srcdir)/../ \
+ -I$(srcdir)/ui/ \
+ -I$(top_builddir)/kopete/protocols/oscar/icq/ui \
+ -I$(srcdir)/../liboscar \
+ $(KOPETE_INCLUDES) $(all_includes)
+
+kde_module_LTLIBRARIES = kopete_icq.la
+
+kopete_icq_la_SOURCES = icqpresence.cpp icqaccount.cpp icqcontact.cpp icqprotocol.cpp
+# icquserinfo.cpp icqreadaway.cpp icqsendsmsdialog.cpp
+
+kopete_icq_la_LDFLAGS = -no-undefined -module $(KDE_PLUGIN) $(all_libraries)
+kopete_icq_la_LIBADD = ../libkopete_oscar.la \
+ $(top_builddir)/kopete/libkopete/libkopete.la ui/libkopeteicqui.la
+
+service_DATA = kopete_icq.desktop
+servicedir = $(kde_servicesdir)
+
+mime_DATA = x-icq.desktop
+mimedir = $(kde_mimedir)/application