summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/yahoo/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /kopete/protocols/yahoo/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kopete/protocols/yahoo/Makefile.am')
-rw-r--r--kopete/protocols/yahoo/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/kopete/protocols/yahoo/Makefile.am b/kopete/protocols/yahoo/Makefile.am
new file mode 100644
index 00000000..6815da99
--- /dev/null
+++ b/kopete/protocols/yahoo/Makefile.am
@@ -0,0 +1,26 @@
+SUBDIRS = libkyahoo ui icons
+METASOURCES = AUTO
+
+AM_CPPFLAGS = $(KOPETE_INCLUDES) \
+ -I$(srcdir)/ui \
+ -Iui \
+ -I$(srcdir)/libkyahoo \
+ $(all_includes)
+
+kde_module_LTLIBRARIES = kopete_yahoo.la
+
+kopete_yahoo_la_SOURCES = yahooprotocol.cpp yahoocontact.cpp \
+ yahooaddcontact.cpp yahooaccount.cpp yahooeditaccount.cpp yahooconferencemessagemanager.cpp \
+ yahoochatsession.cpp yahooverifyaccount.cpp yahoowebcam.cpp
+kopete_yahoo_la_LDFLAGS = -module $(KDE_PLUGIN)
+kopete_yahoo_la_LIBADD = ../../libkopete/avdevice/libkopete_videodevice.la \
+ $(top_builddir)/kopete/libkopete/libkopete.la ui/libkopeteyahooui.la libkyahoo/libkyahoo.la
+
+service_DATA = kopete_yahoo.desktop
+servicedir = $(kde_servicesdir)
+
+
+mydatadir = $(kde_datadir)/kopete_yahoo
+mydata_DATA = yahooconferenceui.rc yahoochatui.rc
+
+