summaryrefslogtreecommitdiffstats
path: root/kpf/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-06-18 10:42:56 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-06-18 10:42:56 +0000
commit153897691d8aa3b17f49555de61ce694ca92fd20 (patch)
treee153643dce4694beba89adb274152cd518785f11 /kpf/CMakeLists.txt
parent87c659b80aefce6e7ab3a6e7442ff8d526a1e51a (diff)
downloadtdenetwork-153897691d8aa3b17f49555de61ce694ca92fd20.tar.gz
tdenetwork-153897691d8aa3b17f49555de61ce694ca92fd20.zip
[kdenetwork/kpf] added cmake support
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1237374 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kpf/CMakeLists.txt')
-rw-r--r--kpf/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/kpf/CMakeLists.txt b/kpf/CMakeLists.txt
new file mode 100644
index 00000000..3f1b82e2
--- /dev/null
+++ b/kpf/CMakeLists.txt
@@ -0,0 +1,25 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( src )
+
+
+##### other data ################################
+
+tde_install_icons( kpf )
+
+install( FILES
+ kpfapplet.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kicker/applets )
+
+install( FILES
+ kpfpropertiesdialogplugin.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR} )