summaryrefslogtreecommitdiffstats
path: root/krdc/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-08 22:39:20 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-08 22:39:20 +0200
commitd36d9267539f12fdaa5a0dd18f6285e4a636e1ac (patch)
tree65966d4e78c0529e0e56f8586a7d9c2ae530d336 /krdc/CMakeLists.txt
parent54888da0ae983555ec963c52007c50d49b3c66af (diff)
downloadtdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.tar.gz
tdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'krdc/CMakeLists.txt')
-rw-r--r--krdc/CMakeLists.txt23
1 files changed, 14 insertions, 9 deletions
diff --git a/krdc/CMakeLists.txt b/krdc/CMakeLists.txt
index a14bd48b..d58b4b45 100644
--- a/krdc/CMakeLists.txt
+++ b/krdc/CMakeLists.txt
@@ -41,17 +41,22 @@ install( FILES
_rfb._tcp
DESTINATION ${DATA_INSTALL_DIR}/zeroconf )
-install( FILES
- krdc.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE krdc.desktop
+ PO_DIR krdc-desktops
+)
-install( FILES
- smb2rdc.desktop
- DESTINATION ${DATA_INSTALL_DIR}/konqueror/servicemenus )
+tde_create_translated_desktop(
+ SOURCE smb2rdc.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqueror/servicemenus
+ PO_DIR krdc-desktops
+)
-install( FILES
- vnc.protocol rdp.protocol
- DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE vnc.protocol rdp.protocol
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR krdc-desktops
+)
##### krdc (executable) #########################