summaryrefslogtreecommitdiffstats
path: root/lanbrowsing/kio_lan/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /lanbrowsing/kio_lan/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'lanbrowsing/kio_lan/Makefile.am')
-rw-r--r--lanbrowsing/kio_lan/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/lanbrowsing/kio_lan/Makefile.am b/lanbrowsing/kio_lan/Makefile.am
new file mode 100644
index 00000000..e0f76e4b
--- /dev/null
+++ b/lanbrowsing/kio_lan/Makefile.am
@@ -0,0 +1,31 @@
+## Makefile.am of kdebase/kioslave/man
+
+INCLUDES= $(all_includes)
+
+####### Files
+
+kde_module_LTLIBRARIES = kio_lan.la
+
+kio_lan_la_SOURCES = kio_lan.cpp
+kio_lan_la_LIBADD = $(LIB_KIO)
+kio_lan_la_LDFLAGS = -module -avoid-version -no-undefined $(all_libraries) $(KDE_RPATH)
+
+noinst_HEADERS = kio_lan.h
+
+kdelnk_DATA = lan.protocol rlan.protocol
+kdelnkdir = $(kde_servicesdir)
+
+remote_DATA = lan.desktop
+remotedir = $(kde_datadir)/konqueror/dirtree/remote
+
+remoteio_DATA = lan.desktop
+remoteiodir = $(kde_datadir)/remoteview
+
+konq_sidebartree_DATA = lisa.desktop
+konq_sidebartreedir = $(kde_datadir)/konqsidebartng/virtual_folders/services
+
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kio_lan.pot
+