summaryrefslogtreecommitdiffstats
path: root/lanbrowsing/lisa/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /lanbrowsing/lisa/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'lanbrowsing/lisa/Makefile.am')
-rw-r--r--lanbrowsing/lisa/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/lanbrowsing/lisa/Makefile.am b/lanbrowsing/lisa/Makefile.am
new file mode 100644
index 00000000..ff1f8433
--- /dev/null
+++ b/lanbrowsing/lisa/Makefile.am
@@ -0,0 +1,41 @@
+##
+AM_CXXFALGS = -fno-rtti -fno-exceptions
+
+#CXXFLAGS = -fno-rtti -fno-exceptions
+
+bin_PROGRAMS = lisa reslisa
+#
+# Programs to compile, Manpages to install and Versions
+#
+#INCLUDES = $(all_includes)
+
+lisa_SOURCES = \
+addressvalidator.cpp \
+netmanager.cpp \
+netscanner.cpp \
+ipaddress.cpp \
+main.cpp \
+mystring.cpp \
+client.cpp \
+configfile.cpp
+
+reslisa_SOURCES = \
+addressvalidator.cpp \
+netmanager.cpp \
+netscanner.cpp \
+ipaddress.cpp \
+strictmain.cpp \
+mystring.cpp \
+client.cpp \
+configfile.cpp
+
+lisa_LDADD = $(LIBSOCKET)
+lisa_LDFLAGS = $(KDE_EXTRA_RPATH)
+
+reslisa_LDADD = $(LIBSOCKET)
+reslisa_LDFLAGS = $(KDE_EXTRA_RPATH)
+
+misc_DATA = README
+miscdir = $(kde_datadir)/lisa
+EXTRA_DIST=$(misc_DATA)
+