summaryrefslogtreecommitdiffstats
path: root/filesharing/advanced/propsdlgplugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'filesharing/advanced/propsdlgplugin/CMakeLists.txt')
-rw-r--r--filesharing/advanced/propsdlgplugin/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/filesharing/advanced/propsdlgplugin/CMakeLists.txt b/filesharing/advanced/propsdlgplugin/CMakeLists.txt
new file mode 100644
index 00000000..f6477d19
--- /dev/null
+++ b/filesharing/advanced/propsdlgplugin/CMakeLists.txt
@@ -0,0 +1,46 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}/../kcm_sambaconf
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES
+ fileshare_propsdlgplugin.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### propsdlgplugin_common (static) ############
+
+tde_add_library( propsdlgplugin_common STATIC_PIC AUTOMOC
+ SOURCES propertiespage.cpp propertiespagegui.ui
+)
+
+
+##### fileshare_propsdlgplugin (module) #########
+
+tde_add_kpart( fileshare_propsdlgplugin AUTOMOC
+ SOURCES propsdlgshareplugin.cpp
+ LINK
+ propsdlgplugin_common-static filesharenfs-static
+ filesharesamba-static kio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)