summaryrefslogtreecommitdiffstats
path: root/kdict/applet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kdict/applet/Makefile.am')
-rw-r--r--kdict/applet/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/kdict/applet/Makefile.am b/kdict/applet/Makefile.am
new file mode 100644
index 00000000..db1f4bc2
--- /dev/null
+++ b/kdict/applet/Makefile.am
@@ -0,0 +1,19 @@
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = kdict_panelapplet.la
+
+kdict_panelapplet_la_SOURCES = kdictapplet.cpp
+
+METASOURCES = AUTO
+noinst_HEADERS = kdictapplet.h
+
+lnkdir = $(kde_datadir)/kicker/applets
+lnk_DATA = kdictapplet.desktop
+
+EXTRA_DIST = $(lnk_DATA)
+
+kdict_panelapplet_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+kdict_panelapplet_la_LIBADD = $(LIB_KSYCOCA) $(LIB_KDEUI)
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/kdictapplet.pot