summaryrefslogtreecommitdiffstats
path: root/kopete/plugins/connectionstatus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kopete/plugins/connectionstatus/Makefile.am')
-rw-r--r--kopete/plugins/connectionstatus/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/kopete/plugins/connectionstatus/Makefile.am b/kopete/plugins/connectionstatus/Makefile.am
new file mode 100644
index 00000000..7fcb3ed8
--- /dev/null
+++ b/kopete/plugins/connectionstatus/Makefile.am
@@ -0,0 +1,12 @@
+METASOURCES = AUTO
+
+AM_CPPFLAGS = $(KOPETE_INCLUDES) $(all_includes)
+
+kde_module_LTLIBRARIES = kopete_connectionstatus.la
+
+kopete_connectionstatus_la_SOURCES = connectionstatusplugin.cpp
+kopete_connectionstatus_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+kopete_connectionstatus_la_LIBADD = ../../libkopete/libkopete.la
+
+service_DATA = kopete_connectionstatus.desktop
+servicedir = $(kde_servicesdir)