summaryrefslogtreecommitdiffstats
path: root/kopete/plugins/cryptography/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kopete/plugins/cryptography/CMakeLists.txt')
-rw-r--r--kopete/plugins/cryptography/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/kopete/plugins/cryptography/CMakeLists.txt b/kopete/plugins/cryptography/CMakeLists.txt
new file mode 100644
index 00000000..4952d8e2
--- /dev/null
+++ b/kopete/plugins/cryptography/CMakeLists.txt
@@ -0,0 +1,53 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( icons )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kopete_cryptography.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES kopete_cryptography_config.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kconfiguredialog )
+install( FILES cryptographyui.rc cryptographychatui.rc DESTINATION ${DATA_INSTALL_DIR}/kopete_cryptography )
+
+
+##### kopete_cryptography (module) ##############
+
+tde_add_kpart( kopete_cryptography AUTOMOC
+ SOURCES
+ cryptographyplugin.cpp kgpginterface.cpp
+ cryptographyguiclient.cpp cryptographyselectuserkey.cpp
+ cryptographyuserkey_ui.ui popuppublic.cpp kgpgselkey.cpp
+ LINK kopete-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### kcm_kopete_cryptography (module) ##########
+
+tde_add_kpart( kcm_kopete_cryptography AUTOMOC
+ SOURCES
+ cryptographypreferences.cpp cryptographyprefsbase.ui
+ kgpgselkey.cpp
+ LINK kopete-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)