summaryrefslogtreecommitdiffstats
path: root/kopete/plugins/highlight/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kopete/plugins/highlight/CMakeLists.txt')
-rw-r--r--kopete/plugins/highlight/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/kopete/plugins/highlight/CMakeLists.txt b/kopete/plugins/highlight/CMakeLists.txt
new file mode 100644
index 00000000..312252bf
--- /dev/null
+++ b/kopete/plugins/highlight/CMakeLists.txt
@@ -0,0 +1,52 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( icons )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete/ui
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kopete_highlight.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES kopete_highlight_config.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kconfiguredialog )
+
+
+##### kopete_highlight (module) #################
+
+tde_add_kpart( kopete_highlight AUTOMOC
+ SOURCES
+ highlightplugin.cpp highlightconfig.cpp filter.cpp
+ LINK kopete-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### kcm_kopete_highlight (module) #############
+
+tde_add_kpart( kcm_kopete_highlight AUTOMOC
+ SOURCES
+ highlightprefsbase.ui highlightpreferences.cpp
+ filter.cpp highlightconfig.cpp
+ LINK kutils-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)