summaryrefslogtreecommitdiffstats
path: root/kopete/plugins/latex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kopete/plugins/latex/CMakeLists.txt')
-rw-r--r--kopete/plugins/latex/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/kopete/plugins/latex/CMakeLists.txt b/kopete/plugins/latex/CMakeLists.txt
new file mode 100644
index 00000000..18433acd
--- /dev/null
+++ b/kopete/plugins/latex/CMakeLists.txt
@@ -0,0 +1,53 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( icons )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete/ui
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kopete_latex.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES kopete_latex_config.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kconfiguredialog )
+install( FILES kopete_latexconvert.sh DESTINATION ${BIN_INSTALL_DIR} )
+install( FILES latexconfig.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
+install( FILES latexchatui.rc DESTINATION ${DATA_INSTALL_DIR}/kopete_latex )
+
+
+##### kopete_latex (module) #####################
+
+tde_add_kpart( kopete_latex AUTOMOC
+ SOURCES
+ latexplugin.cpp latexconfig.kcfgc latexguiclient.cpp
+ LINK kopete-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### kcm_kopete_latex (module) #######################
+
+tde_add_kpart( kcm_kopete_latex AUTOMOC
+ SOURCES
+ latexprefsbase.ui latexpreferences.cpp latexconfig.kcfgc
+ LINK kutils-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)