summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/jabber/tdeioslave/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kopete/protocols/jabber/tdeioslave/CMakeLists.txt')
-rw-r--r--kopete/protocols/jabber/tdeioslave/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/kopete/protocols/jabber/tdeioslave/CMakeLists.txt b/kopete/protocols/jabber/tdeioslave/CMakeLists.txt
new file mode 100644
index 00000000..aaf788bd
--- /dev/null
+++ b/kopete/protocols/jabber/tdeioslave/CMakeLists.txt
@@ -0,0 +1,42 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/..
+ ${CMAKE_CURRENT_SOURCE_DIR}/../libiris/iris/include
+ ${CMAKE_CURRENT_SOURCE_DIR}/../libiris/iris/jabber
+ ${CMAKE_CURRENT_SOURCE_DIR}/../libiris/iris/xmpp-im
+ ${CMAKE_CURRENT_SOURCE_DIR}/../libiris/cutestuff/util
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES jabberdisco.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### kio_jabberdisco (module) ##################
+
+tde_add_kpart( kio_jabberdisco AUTOMOC
+ SOURCES jabberdisco.cpp
+ LINK
+ jabberclient-static
+ iris_xmpp_core-static iris_xmpp_im-static iris_jabber-static iris-static
+ qca-static cutestuff_network-static cutestuff_util-static tdeio-shared idn
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)