summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/jabber/ui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kopete/protocols/jabber/ui/CMakeLists.txt')
-rw-r--r--kopete/protocols/jabber/ui/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/kopete/protocols/jabber/ui/CMakeLists.txt b/kopete/protocols/jabber/ui/CMakeLists.txt
new file mode 100644
index 00000000..a4488d62
--- /dev/null
+++ b/kopete/protocols/jabber/ui/CMakeLists.txt
@@ -0,0 +1,43 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}/../../../libkopete/ui
+ ${CMAKE_CURRENT_SOURCE_DIR}/..
+ ${CMAKE_CURRENT_SOURCE_DIR}/../libiris/iris/include
+ ${CMAKE_CURRENT_SOURCE_DIR}/../libiris/iris/jabber
+ ${CMAKE_CURRENT_SOURCE_DIR}/../libiris/iris/xmpp-im
+ ${CMAKE_CURRENT_SOURCE_DIR}/../libiris/qca/src
+ ${CMAKE_CURRENT_SOURCE_DIR}/../libiris/cutestuff/util
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../../libkopete
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../../libkopete/ui
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+
+##### kopetejabberui (static) ###################
+
+tde_add_library( kopetejabberui STATIC_PIC AUTOMOC
+ SOURCES
+ dlgsendraw.ui dlgjabbersendraw.cpp dlgaddcontact.ui
+ jabberaddcontactpage.cpp dlgvcard.ui dlgjabbervcard.cpp
+ dlgjabberservices.cpp dlgregister.ui dlgjabberregister.cpp
+ dlgbrowse.ui dlgjabberbrowse.cpp dlgjabbereditaccountwidget.ui
+ jabbereditaccountwidget.cpp dlgjabberregisteraccount.ui
+ jabberregisteraccount.cpp dlgjabberchooseserver.ui
+ jabberchooseserver.cpp dlgchangepassword.ui
+ dlgjabberchangepassword.cpp empty.cpp dlgchatroomslist.ui
+ dlgjabberchatroomslist.cpp dlgchatjoin.ui dlgjabberchatjoin.cpp
+ dlgservices.ui
+)