summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/oscar/icq/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kopete/protocols/oscar/icq/CMakeLists.txt')
-rw-r--r--kopete/protocols/oscar/icq/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/kopete/protocols/oscar/icq/CMakeLists.txt b/kopete/protocols/oscar/icq/CMakeLists.txt
new file mode 100644
index 00000000..20f8b11a
--- /dev/null
+++ b/kopete/protocols/oscar/icq/CMakeLists.txt
@@ -0,0 +1,45 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( ui )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/ui
+ ${CMAKE_CURRENT_SOURCE_DIR}/..
+ ${CMAKE_CURRENT_SOURCE_DIR}/../liboscar
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete/ui
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kopete_icq.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES x-icq.desktop DESTINATION ${MIME_INSTALL_DIR}/application )
+
+
+##### kopete_icq (module) #######################
+
+tde_add_kpart( kopete_icq AUTOMOC
+ SOURCES
+ icqpresence.cpp icqaccount.cpp icqcontact.cpp icqprotocol.cpp
+ LINK
+ kopeteicqui-static kopete_oscar-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)